❓ Support
Subarist Subarist May 28, 2023

An error occurred during the search execution.

An error occurred during the search execution.


Where should I troubleshoot? Or where can I access the log files?

Answered by Toby Toby

I've made a change in 0.2 that should fix this. The posts with invalid XML just won't display an excerpt.

View Answer

⁨5⁩ ⁨Comments⁩

The reason for this problem seems to be that I skipped the XML check and imported a database text that doesn't comply with the specified format.


I believe that the issue arises when the invoked text does not comply with XML formatting.
When I imported a database text that adhered to the specified format, the search function worked flawlessly.
Searching for English words produced accurate results, and UTF8 characters were no display as expected.

Is there a straightforward method to disable the XML check when invoking the search function?
It seems that this problem doesn't occur in Flarum.


Also happens when setting summary display, if it has illegal syntax.
The articles in this test tag are all articles created in flarum. Just copying HTML articles from other websites and pasting them seems to cause the same error.