💡 Ideas
R Ryan Pitts Apr 3, 2024

Support for Laravel 11?

I have an existing Laravel application that is on Laravel 11. Tried installing Waterhole into the application but the composer command fails due to it only supporting Laravel 10.

Are there plans and a potentital timeline to add support for Laravel 11?

Very interested to try this software in our application but unfortunately might have to pivot if it won't be available for a while.

⁨10⁩ ⁨Comments⁩

In reply to Toby Toby

Appreciate the response, @Toby! I might be able to hold off until it's ready.

We just updated our app from 10.x to 11.x and it was pretty painless. Took about a day.

In reply to Toby Toby

Hey @Toby, just to try and test things out, i forked your repo and upgraded things to work with Laravel 11. I'm just having trouble with getting the assets CSS and js to load. I've not done much with composer packages but I assume they need to be built in the package repo. What command should i use to build them? And is there anything i would need to do within my app to get things to load since I'm using it with a Laravel integration?

Toby Toby Waterhole Founder Apr 16, 2024
In reply to R Ryan Pitts

Laravel 11 support has been added in 0.4.8 🎉

@Ryan Pitts Hopefully you're able to switch back over to the official package - let me know if any issues. But for future reference, the command to compile Waterhole's assets is npm run prod.

In reply to Toby Toby

Yep, i can switch over! I was just playing around with it.

Thanks for getting the Laravel 11 support work completed!

In reply to Toby Toby

@Toby i have it all setup and running within my app now. The only part I'm a little stuck on is how do i get Waterhole to create user records in its users table for my existing users?

I tried logging out and logging back in thinking the traits and everything i added to my user model class would force it to create the record if it didn't exist.

I also tried just navigating to the forum while logged in and it just sent me to the forums login screen.

I did adjust these settings in the config/waterhole/auth.php file:

'allow_registration' => false,
'password_enabled' => false,

Possible that I am missing something?

In reply to Toby Toby

Hey Toby, I'm assuming 0.4.8 is yet to be released? As composer update doesn't pull in that version nor does starting a new project via composer create-project waterhole/waterhole path/to/forum.

Toby Toby Waterhole Founder Apr 21, 2024
In reply to R Ryan Pitts

@Ryan Pitts Can I clarify, what do you actually see when you navigate to the forum while logged in? The current behaviour is that Waterhole won't create the user immediately, but will present a pre-filled registration form allowing the user to customise their username. It shouldn't be possible to see a login screen if password_enabled is false and there are no authentication providers in your config.

In reply to Toby Toby

I think I figured out the issue, waterhole/core requires a beta version of turbo-laravel:

waterhole/core v0.4.8 requires hotwired-laravel/turbo-laravel ^2.0.0-beta5 -> found hotwired-laravel/turbo-laravel[2.0.0-beta5, 2.x-dev] but it does not match your minimum-stability.

Also, the Waterhole Starter Skeleton project has the following in the composer.json:

    "minimum-stability": "stable",
    "prefer-stable": true

Is there any risk of switching minimum stability to beta? That was the only way I was able to update the Waterhole Starter Skeleton project.